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System Requirements 

The following information outlines the minimum and recommended system requirements to run Alastri Spacial 

Conformetrics. As the hardware required depends on the complexity of the mine and the amount of data, 

meaningful minimum requirements cannot always be listed. Ultimately the only way to know whether 

specific hardware will work for a specific mine site is to validate the software's performance during the free trial 

period. 

• For large multi-pit mines with raw LIDAR surfaces and block models with 80M blocks the requirements will 
be at the extreme end. 

• The minimum requirements will only support small mines with a small block model and surfaces with low 
triangle counts. 

• Please note that as our software develops over time, these requirements may change, and hardware 
upgrades may become necessary. 

Note: Running Alastri Spacial Conformetrics on minimum system requirements may slow the application response, 

depending on the size of the model. Use recommended requirements for optimal use. 

Component Minimum Standard Extreme 

Processor Intel i5 Intel i7 Intel i9 

Memory (RAM) 8 Gb 64 Gb 128 Gb 

Operating System Windows 10 x64 Windows 10 x64 Windows 10 x64 

Video Memory (GRAM) 2 Gb 8 Gb 12 Gb 

Monitor 1920 x 1080 Dual 1920 x 1080 Triple 1920 x 1080 

Video Connection HDMI, DisplayPort, DVI, VGA - USB not supported 

Video Driver Driver no more than 6 months old (OpenGL 4.6+) 

Hard Drive Solid State Drive with at least 50 GB Free 

Power Connection AC Power - Battery power not supported (plug in the laptop) 

Network Connection Consistent, reliable, high speed (>1 MB/s) connection to the Internet 

Software Prerequisites .NET 4.7.2 

Microsoft Visual Studio 2019 C++ Redistributables 
(https://aka.ms/vs/16/release/vc_redist.x64.exe) 

Microsoft Excel 

Input Devices Keyboard and Mouse with a left mouse button, right mouse button, and middle 
mouse button/scroll wheel 

 

"Element Not Found" 

Many IT departments block downloads of Microsoft prerequisites, so you may need to download them manually. 

The installation error "Element Not Found" indicates that you must download and install these manually. 

• Microsoft .NET Framework 4.5.1 

• Microsoft VSTO Runtime for Office 2010 

https://aka.ms/vs/16/release/vc_redist.x64.exe
http://go.microsoft.com/fwlink/?LinkId=322116
http://go.microsoft.com/fwlink/?LinkId=158917


Installation and Setup 

Prerequisite 

It is important to note that the System Requirements should be met to run the software. 

Many IT departments block downloads of Microsoft prerequisites, so you may need to download them manually. 

If any error whatsoever occurs on install, ensure that you have downloaded and installed these manually. 

• Microsoft .NET Framework 4.5.1 

Spacial Conformetrics requires Windows 10 or higher (64 bit only) 

Installation 

Follow these steps to get started with Alastri Spacial Conformetrics. 

Alastri Login 

New users may proceed to the licensing page and click Register as a new user. Please check your inbox for a 

confirmation email to finalise your account. 

 

Get Licensed 

Choose from the following options to license your account with chosen Alastri products.  

• Ask your manager to log in as a License Admin and add you to the company license, or 

• Email support@alastri.com.au for assistance.  

Download the Hub 

The Hub manages all Alastri product release versions and licenses. It can be downloaded by logging 

into the licensing page and pressing Download Alastri Hub. 

http://go.microsoft.com/fwlink/?LinkId=322116
https://licensing.alastri.com.au/
mailto:support@alastri.com.au
https://licensing.alastri.com.au/


Install the Hub 

Once the Hub has finished downloading, run the executable and click Confirm on security prompts to continue the 

install. 

 

Note that Alastri products will always be signed with "Verified Publisher: Alastri Software Pty Ltd".  

Wait until the download is complete and click Close. 

 

Even if you have administrative privileges you should install the Hub by right clicking on the Alastri.Hub.2.0.*.exe 

file and run as administrator. 



Login to the Hub 

Double click on the Hub shortcut, or click Start > Alastri Hub, to open the Hub login form.  

 

Enter your email and password into the login form and press Login to continue.  

The Hub uses the same password credentials as the licensing website. Passwords can be reset here. 

Configure Proxy 

If you are connecting through a company proxy, press Proxy Settings in the bottom right corner of the login form.  

 

https://licensing.alastri.com.au/Account/ForgotPassword


 

Contact your IT department to obtain the correct proxy credentials for your organisation.  

Install Products 

In the main Hub form: 

1. Select Spacial Conformetrics from the left hand product menu. 
2. Select the latest version. 
3. Press Install. 

 



Graphics & Compatibility 

Graphics Card Settings 

Follow these steps to ensure Spacial Conformetrics runs smoothly on your computer. Note that your screen and 

settings may differ from those shown here. 

Check Your Graphics Card 

Spacial Conformetrics requires a dedicated graphics card by NVidia or ATI to run. To check your graphics card, go to 

Windows Start > Control Panel > Hardware and Sound > Device Manager > Display Adapters. 

 

Open the Control Panel and search for the Device Manager 



 

Find the graphics card details listed under the Display Adapters  

If you are running a computer without a dedicated graphics card, then you will need to upgrade your computer to 

run Spacial Conformetrics. 

If you do have an appropriate dedicated graphics card, then proceed to the next step. 

Update Graphics Drivers 

Alastri products require the latest graphics card drivers for best performance. 

 

If you see this message, follow these links to download and run the latest graphics card drivers. 

• NVidia Driver Downloads 

• ATI Driver Downloads 

• Intel Driver Downloads 

http://www.nvidia.com/Download/index.aspx?lang=en-us
http://support.amd.com/en-us/download
https://downloadcenter.intel.com/


Change the Default Graphics Processor 

If any graphics related issues arise, navigate to the graphics card control panel and set Alastri products to run in 

high-performance mode.  

NVidia Graphics Cards 

If you have an NVidia graphics card, it may be defaulting to the integrated graphics card instead of the higher 

performance NVidia graphics card.  

To change the default video card for Spacial Conformetrics: 

1. Right click on your desktop and select “NVidia Control Panel”. 

 

2. Select “Manage 3D settings”. 

3. Select “Program Settings”. 



 

4. Choose “Spacial Conformetrics” from the dropdown menu. 

• Or navigate to %localAppData%\Alastri Hub\Programs\PROGRAM\VERSION\3DMARK.exe. 

5. Select your NVidia graphics card under "preferred graphics processor". 

ATI Graphics Cards 

If you are using an ATI graphics card, it may be defaulting to the integrated graphics card instead of the higher 

performance ATI graphics card. 

To change the default video card to Spacial Conformetrics: 

1. Right click on the desktop and open Catalyst Control Center. 

2. Select “Power” from the left hand menu. 

3. Select “Switchable Graphics” from the list. 

4. Browse the list of programs and find SpacialConformetrics.exe (or C:\Program Files\Alastri 

Software\Alastri SpacialConformetrics v21.2.981\ SpacialConformetrics.exe). 

5. Set RapidReserver.exe to “High Performance”. 

6. Apply changes and restart your computer. 



Vulcan User Settings 

These notes apply if you are importing surfaces from Maptek Vulcan. Spacial Conformetrics requires Vulcan 

surfaces to be in file format version 7.5 or earlier in order to import and use them. 

In Vulcan, go to Tools > Preferences > File Types > Triangulations and change the file format to Version 7.5. Vulcan 

requires a restart for the changes to take effect. 

If you do not want to change Vulcan's formatting, use File > Export to DXF and import to Spacial Conformetrics as a 

DXF file. 

 

Spacial Conformetrics requires Vulcan triangulations to be version 7.5 

  



Surpac User Settings 

These notes apply if you are importing surfaces from Geovia Surpac. Spacial Conformetrics requires Surpac 

surfaces to be saved in text format in order to import and use them.  

 

This error message is caused by trying to import a Surpac DTM in binary format 

 

When saving surfaces in Surpac, set file format to text 

Battery Power Settings 

To prevent laptops from switching back to Intel graphics on lower power mode, go to Power Options > High 
Performance > Advanced Power Settings and change all options to maximum performance.  

Work Locally 

Alastri recommends saving all project files and data on the local hard drive before transferring to the network. This 
avoids issues with saving over interrupted connections or reading from a slow connection. 



Work Offline 

Licenses may be used offline by using the Extended Checkout feature in the Hub.  

In the main Hub form: 

1. Select an item from the left hand product menu. 
2. Press Extended Checkout. 
3. Enter the hours to checkout the license. 
4. Press OK 

 

✓ This will lock the license to your machine (online and offline) for the duration of the checkout.  

Note that license cannot be checked back in until the timer runs out. 

Permissions 

Users may encounter the "Access is denied" error message when attempting to open a project file via the Hub or 
from Windows Explorer. 

Stack Trace: System.ComponentModel.Win32Exception (0x80004005): Access is denied 



This error occurs when the helper process "PolygonicaService.exe" is blocked from running by a virus scanner, group 
policy, or Windows compatibility profiles. 

Virus Scanner 

Virus scanners may block PolygonicaService.exe, or prevent it from launching. Adding a whitelist / exception for this 

process can help avoid "Access Denied" errors. 

The Alastri Hub installs products into the following location: %localappdata%\Alastri Hub\Programs. 

Group Policy 

Occasionally group policy configuration may prevent applications from being launched from AppData\Local on 

machines. 

Your IT administrators may need to provide an exception for Spacial Conformetrics to allow it to operate correctly. 

Program Compatibility Assistant 

In order to allow legacy software to work on your system, your IT department may have created a program 

compatibility profile which causes Windows to run applications with non-standard behaviour. This can affect Spacial 

Conformetrics’s ability to track instances of PolygonicaService.exe and make sure they are cleanly shutdown with 

the application. 

Your IT administrators may need to modify the application compatibility profile to avoid affecting Spacial 

Conformetrics. 

Warnings 

Users may encounter the "Application Compatibility Profile" warning when attempting to install the Hub. 

“We have detected an application compatibility profile on your machine, which may interfere with installation of Alastri Hub” 

 



Serious problems might occur if you modify the registry incorrectly. Contact your IT department to resolve this 

issue. 

✓ If you are a competent IT professional: 

This issue may be resolved via the following steps: 

1. Click on Start, type in "regedit" and run the command. 
2. Browse to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows 

NT\CurrentVersion\AppCompatFlags\Custom. 
3. Rename setup.exe to _setup.exe. 

Project Files 

When Spacial Conformetrics is saved, multiple different files will appear in the save location. 

.inf Spacial Conformetrics project file 

.lock Locks out a file to one user at a time 

.old 
If the main project files are corrupted for any reason, the “.old” files can be restored as 
functional project files by removing “.old” from the file name 

.resultCache Reduces scheduling time by saving results of previous runs 

.layers 
Saves triangulations external to the main project. Deleting the “.layers” file is the same as 
deleting all layers from the project 

.drapeImages 
Saves draped images external to the main project. Deleting the “.drapeImages” file is the 
same as deleting all draped images from the project 

  



Internet License FAQ 

Do I need an internet license? 

Alastri software uses standard Internet-based authorisation. If you are in a remote location with a poor 

connection, or no internet connection at all, then you may wish to enquire about dongle based authorisation. 

How does my internet license work? 

The internet license authenticates your purchase key, name and email against your details on the Alastri server. 

Does the internet license require any special software? 

The license does not require any special software to be installed. 

How do I know if the license is working? 

The licensing dialog will inform you of any authentication errors. 

Can I check out my internet license overnight? 

You can use the Extended Checkout feature to hold licenses offline for a number of hours. Normally the maximum 

checkout time for licenses is seven days. 

Checked out licenses cannot be released before their expiry date. 

 

 

  



Internet License Troubleshooting 

Why is my license asking for browser authentication? 

Your IT department may be restricting applications from connecting to the internet. In this case, Alastri connects 

through a browser instead. Talk to your IT department about network permissions for Alastri products. 

Why is my name not found? 

The internet license authenticates your purchase key, name and email against your details on the Alastri server. 

Check for spelling errors in your name; if problem persists then contact Alastri support. 

 

Why is my email not found? 

The internet license authenticates your purchase key, name, and email against your details on the Alastri server. 

Check for spelling errors in your email, if problem persists then contact Alastri support. 

 

  



Why are there no available seats on the license? 

Each Alastri license can be shared between a number of users. Ask your colleague if they can release the license for 

your use. 

 

What is "License tampering detected" and how can I fix it? 

The internet licensing system checks to make sure that the computer's date and time is correct, to ensure that 

checked out licenses expire properly. If you see this message, make sure that your computer's date and time is 

updated. 

What do I do if my license has expired? 

Save and close your project and talk to your supervisor about renewing your license. 

Hub Login Failure 

Invalid Username or Password Entered 

If the user encounters the Login Failed form, please re-enter your correct username and password. 

 

 

 



Forgotten Password and Reset 

Should the user forget their password, the Hub login form features the option for the user to Reset the password 

(Reset Password button). This will take them to the Alastri website where the user can enter their email address. 

An email will be sent to the entered email address with a password reset link. 

 

 

Unable to Connect 

If the user is unable to connect to the Hub due to connection loss, several steps can be taken to try and rectify this. 

If the user is presented with a Hub login screen that doesn't complete and seems to freeze, or a message 

communicating No Connection, then most often the problem is on the user end with permissions blocking access 

to the required files and web addresses. 



 

 

Please try the following in order: 

1. Open up a file explorer. 
2. In the file path, type the following “%localappdata%”. 
3. Go into the Alastri Hub Folder. 
4. Go into the Cache folder. 
5. Delete the contents inside. 
6. Restart the Hub. 

If still unable to connect this usually indicates that your connection is blocked and will require 

intervention by IT.  

1. To try and resolve this you will need to get IT to add https://alastribuild.azureedge.net/ to the whitelist. 
2. Virus scanners will also need to allow Alastri access to the following address: 

C:\Users\username\AppData\Local\Alastri Hub. 
3. Try access the following link https://alastribuild.azureedge.net/media/rr/background.jpg. You should see 

an image of an open pit operation. 
4. Repeat Steps 1-6. 

If still unable to access the Hub, try the following steps: 

1. If you use a proxy you will need to enter the details. 
2. Repeat steps 1-6. 
3. If your IT  team tell you they have an auto proxy and you still can't login, tell them to try specific proxy for 

your machine. 
4. Repeat Steps 1-6. 
5. Contact Alastri.  

https://alastribuild.azureedge.net/
https://alastribuild.azureedge.net/media/rr/background.jpg


Dongle License FAQ 
Do I need a dongle?  

Alastri software uses standard Internet-based authorisation. If you are in a remote location with a poor 

connection, or no internet connection at all, then dongle authorisation may be the best solution for your needs. 

How do I obtain a dongle for my license? 

Please contact Alastri Support to discuss your requirements. 

How do I use the dongle? 

The dongle does not require any special configuration to use. Simply insert the dongle into a USB port on the 

computer and use the application as normal. In a normal state after the dongle is attached to the computer the 

LED will be on all the time. 

Do I still need to enter my purchase key? 

Yes, every login requires authentication of your purchase key, name, and email address. 

Does the dongle require any special software? 

The dongle does not require any special software to be installed. 

How many dongles do I require? 

A single dongle is required per computer per license key. It is possible to share one license across multiple dongles. 

Contact Alastri Support to discuss your requirements. 

What do I do if I have lost my dongle? 

Contact Alastri Support to discuss replacing your dongle. 

How do I know the dongle is working? 

Once a dongle is recognised by the computer, the dongle ID will show in the licensing dialog. 



 

When can I pull out my dongle? 

You should only pull out the dongle once the software has been shut down. 

If unplugged while writing/reading, your unsaved data may be lost. 

Dongle License Troubleshooting 

There are times when dongles are not immediately recognised by the software or the computer. Take these steps 

to check and resume the USB connection 

Why is my dongle is flashing? 

The dongle LED indicates the status of the dongle. In a normal state after the dongle is attached to the computer 

the LED will be on all the time. If the LED blinks it indicates that the driver is not installed. Other LED responses 

indicate hardware failure. 



Why is my dongle recognised as an Unknown Device? 

This problem occurs occasionally. Generally, your device is not attached properly to the computer, or some 

interference exists. Remove your dongle and try to attach it again through a different USB port. 

My computer recognises the dongle, but the application is still asking me to insert a dongle. 
What do I do? 

1. With the dongle inserted, exit, and restart the application.  
2. Insert the dongle into a different USB port and restart the application. 
3. With the dongle inserted, reboot your computer, and restart the application. 
4. Insert a different dongle, then switch back. 
5. Contact Alastri Support to exchange your dongle. 

 


